Back to overview
Maintenance

🔧 Security Maintenance Underway

Mar 7, 2026 at 3:02pm UTC  –  Mar 7, 2026 at 5:43pm UTC
Affected services
Game Panel Web
Game Server MTL Valhala
Game Server MTL Ryzen
Game Server MTL Gevo
Game Server MTL Thor

Resolved
Mar 7, 2026 at 5:43pm UTC

Security Maintenance Completed

The security maintenance is now complete. The client panel is fully accessible again.

Thank you for your patience and cooperation during this time.

Game servers are active and everything is running normally.

Created
Mar 7, 2026 at 3:02pm UTC

🔧 Security Maintenance Underway

A security maintenance has been initiated and will be ongoing for the next 8 hours.

During this period, the client panel may not be accessible. We apologize for any inconvenience and thank you for your understanding.

✅ Game servers remain active and no disruption is expected on that end.